Необходимо написать программу в паскале вставить по одному элементу с заданным значением перед всеми отрицательными элементами массива.

pakhomovalexandra pakhomovalexandra    1   07.07.2019 22:30    1

Ответы
1ЛиКа6 1ЛиКа6  31.07.2020 01:15
Var
  a:array[1..10] of integer;
  n,i:integer;
begin
  readln(n);
  for i:=1 to 10 do begin
    a[i]:=random(-10,10);
    if (a[i] < 0) and (i > 1) then begin
      if a[i-1] > 0 then a[i-1]:=n;
    end;
    if (a[i] < 0) and (i = 1) then write(n:3);
  end;
    for i:=1 to 10 do write(a[i]:3);
end.
ПОКАЗАТЬ ОТВЕТЫ
Ynushkevich333 Ynushkevich333  31.07.2020 01:15
Другие вопросы по теме Информатика