Необходимо написать программу на паскале, которая будет удалять из строки все стоящие подряд одинаковые элементы, если их больше 2. примеры: aabbbc -> aac; aabbbac -> c;

daria151174 daria151174    2   13.07.2019 20:20    6

Ответы
Marat445372 Marat445372  20.09.2020 08:22
Рекурсивный подход.(Символы тоже удаляет)
function grad(s:string):string;
var
i:byte;
detect:boolean;
begin
while i < length(s) - 2 do
begin
inc(i);
if (s[i] = s[i+1]) and (s[i] = s[i+2]) then {проверка последовательности из 3 елементов}
begin
delete(s,i,3); {если да - удаляем их}
detect:=True; {логическая переменная регистрирует изменение строки}
end;end;
if detect = True then
s:=grad(s); {если строку изменили , проверяем не появились ли там еще последовальности}
grad:=s; 
end;

var
s:string;
begin
readln(s);
writeln(grad(s));
end.
ПОКАЗАТЬ ОТВЕТЫ
0505levon 0505levon  20.09.2020 08:22
Var s:string; c:char; i:integer;
begin
write('s = '); readln(s);
i:=1;
while (i+2<=length(s)) do
 if(s[i]=s[i+1])and(s[i+1]=s[i+2])
  then begin
        c:=s[i];
       while (i<=length(s))and(c=s[i]) do delete(s,i,1);
       i:=1;
       end
  else i:=i+1;
writeln(s);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика