tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Необходимо написать программу,
Необходимо написать программу, которая вычислит сумму 1+1/3+1/3^2++1/3^n на языке c++, используя цикл for
НастяMokrik
3 19.09.2019 20:20
3
Ответы
виктория2003141
08.10.2020 02:58
Microsoft VS 2017 (C++)
#include<iostream>
using namespace std;
double find(int n) {
double rez = 1.;
for (int i = 1; i <= n; i++) {
rez += 1 / pow(3, i);
}
return rez;
}
int main() {
int n; cin >> n;
cout << find(n) << endl;
system("pause");//если не компилируется, поменяй эту строку //на getchar()
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
745632189
08.10.2020 02:58
#include <iostream>
#include <cmath>
using namespace std;
typedef unsigned u;
int main()
{
u N = 3;
double s = 1.0;
for (u i = 1; i <= N; ++i) {
s += 1.0 / pow(3.0, i);
}
cout << s;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
buslabik1
26.01.2021 08:56
Задача на Паскале: Дан фрагмент программы (все переменные – integer): z:=0; u:=x; repeat z:=z+y; u:=u-1 until u=0; Выполните этот фрагмент с заданными x=10, y=8. Чему равно z после...
ВикаКотик283627
26.01.2021 08:53
Тіл алфавиті. синтаксис Оқулықтың 77-80 беттер аралығын түсіне оқып, 80 беттегі Ойлануға берілген сұрақтарға жауап береміз. дәптерге орындап, суретке түсіріп жібереміз!...
FruitAPps
09.06.2019 03:50
Составить ) в pascal abc в последовательности действительных чисел a1, а2, аn есть только положительные и отрицательные элементы. вычислить произведение отрицательных элементов р1...
dashanovikova03
09.06.2019 03:50
~какую операцию нельзя применить к каталогу:...
svetlana1980ang
30.07.2019 04:50
Составь для чертёжника алгоритм создания данного чертежа. каждая фигура рисуется с выделенной точки. работу выполняй по плану...
ПолинаПашкова14
15.09.2021 09:06
Какое действие не рекомендуется выполнять при включённом компьютере...
Lichnosti
15.09.2021 08:52
1 + + X = 84 Результат запишите в восьмеричной системе счисления....
Изачка
20.06.2019 01:00
Нужна . цифровой бланк оплаты услуги за пользование электроэнергией имеет вид: лицевой счет – поле из 12 цифр, месяц – поле длины 8 в алфавите из 22 символов, год – поле из 2 цифр,...
dasha54321d
27.06.2019 03:00
Вставь пропущенные числа и знаки действий. ответ напиши в виде строки чисел со знаками действий перед ними. 15 -- 45 -- 5 -- 80 -- 2...
koool3
27.06.2019 03:00
Вмагазин 10 ящиков яблок по 3,6 кг в одном ящике и 40 ящиков яблок по 3,2 кг в ящике. сколько в среднем килограмм яблок в одном ящике....
Популярные вопросы
Втреугольнике бсд точки о, р и к середины сторон. определить периметр треугольника...
2
1)выделите целую часть дроби 327/21 а)12 б)25 в)11 г)15 2)превратите 3 31/53 в неправильную...
1
Механика ледяная горка составляет с горизонтом угол 30градусов. из некоторой точки...
3
Формула в электронных таблицах не может включать ; а) текст; б) числа; в) знаки...
3
Какой объем занимает газ, находящийся под давлением 1,33 па и при температуре 7...
2
Диапазон ячеек электронной таблицы задается: а) номерами строк первой и последней...
3
Колебательный контур содержит сопротивление 1 ом, катушку индуктивностью 25 мгн...
3
Viii. составьте предложения из данных слов: 1. a, works, he, farm, on. 2. you, do,...
1
Электронная таблица-это: а) устройство ввода графической информации; б) компьютерный...
1
Ум- это духовное оружие человека (эссе) !...
1
#include<iostream>
using namespace std;
double find(int n) {
double rez = 1.;
for (int i = 1; i <= n; i++) {
rez += 1 / pow(3, i);
}
return rez;
}
int main() {
int n; cin >> n;
cout << find(n) << endl;
system("pause");//если не компилируется, поменяй эту строку //на getchar()
return 0;
}
#include <cmath>
using namespace std;
typedef unsigned u;
int main()
{
u N = 3;
double s = 1.0;
for (u i = 1; i <= N; ++i) {
s += 1.0 / pow(3.0, i);
}
cout << s;
}