Необходимо написать программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 2.программа получает на вход количество чисел в последовательности, а затем сами числа. в последовательности всегда имеется число, оканчивающееся на 2.количество чисел не превышает 1000. введённые числа не превышают 30 000. программа должна вывести одно число — максимальное число, оканчивающееся на 2.

Соничка55555 Соничка55555    1   12.03.2019 23:52    7

Ответы
Milokgre Milokgre  25.05.2020 03:08

var n,a,i,max:integer;

begin

readln(n);

max:=0;

for i:=1 to n do

begin

read(a);

if (a mod 10=2)and(a>max) then max:=a;

end;

writeln(max);

end.

Пример:

17 20 12 41 15 5 52 10

52

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика