Необходимо написать программу, которая проверяет, знаете ли вы таблицу умножения. Программа выводит на экран пример, ответ на который должен ввести пользователь. Программа должна вывести на экран, верно ли ответил пользователь, и показать правильный результат, если пользователь ответил неверно.
Генерируйте пример с генератора случайных чисел (random, randint)
Таблица умножения включает в себя числа от 1 до 9
В программе должно быть ветвление if

Бика2525 Бика2525    1   26.03.2020 18:30    10

Ответы
Лучший1111кар Лучший1111кар  27.08.2020 23:57

import random

while True:

       a = random.randint(1, 9)

       b = random.randint(1, 9)

       i = 0

       while True:

               try:

                       print("%dx%d=" % (a, b), end="")

                       i = int(input())

               except ValueError:

                       print("Введите число!")

               else:

                       break

       rightAnswer = a * b

       if i == rightAnswer:

               print("Верно!\n")

       else:

               print("Неверно! Верный ответ: %d\n" % rightAnswer)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика