Не особо шарю в паскале. нужна . нужно написать программу для определения какой четверти принадлежит точка. мне не нужно решение из интернета, без комментариев и прочего. по возможности с объяснением, а то дальше не вытяну информатику

gennadih90 gennadih90    2   22.08.2019 19:40    2

Ответы
amekekes amekekes  05.10.2020 13:18
Var  x,y:integer; 
begin
writeln('Программа определения местонахождения точки');
writeln('Введите координаты точки');
readln(x,y); //вводим координаты точки 
if (x>=0) and (y>=0) then writeln('1 четверть'); //точка принадлежит 1 ч. если обе координаты положительны (это из геометрии)
if (x<0) and (y>=0) then writeln('2 четверть'); //точка принадлежит 2 ч. если х<0, а y неотрицателен (это из геометрии)
if (x<0) and (y<0) then writeln('3 четверть'); //точка принадлежит 3 ч. если обе координаты отрицательны (это из геометрии)
if (x>=0) and (y<0) then writeln('4 четверть'); //точка принадлежит 4 ч. если х неотрицателен, а y<0 (это из геометрии)
end.  
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика