Не могу написать программу на языке паскаль. даны три целых двузначных числа. из наибольшего из них вычесть наименьшее и сравнить результат с оставшимся числом. если полученное число будет больше вывести yes в противном случае no.

fghjdgfdjhg fghjdgfdjhg    1   21.06.2019 14:20    1

Ответы
Rinaaaaaa Rinaaaaaa  02.10.2020 07:31
Var
  a,b,c,max,mid,min,t:integer;
begin
  Writeln('Введите через пробел три целых двухзначных числа');
  Readln(a,b,c);
  if a>b then begin max:=a; min:=b end
  else begin max:=b; min:=a end;
  if max<c then begin mid:=max; max:=c end
  else mid:=c;
  if min>mid then begin t:=mid; mid:=min; min:=t end;
  if (max-min)>mid then Writeln('YES')
  else Writeln('NO')
end.

Тестовое решение:
Введите через пробел три целых двухзначных числа
37 93 74
NO
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика