tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Найти все двузначные числа,которые
Найти все двузначные числа,которые кратны числу n(программирование паскаль)
kkatya322
1 25.07.2019 09:50
1
Ответы
Rosalin1
24.09.2020 12:35
//Pascal ABC.NET v3.1 сборка 1172
//Продвинутый вариант
Var
n:integer;
begin
readln(n);
range(10,99).Where(x -> x mod n=0).Print(',');
end.
//"Школьный" вариант
Var
i,n:integer;
begin
readln(n);
for i:=10 to 99 do
if i mod n=0 then write(i,',');
end.
Пример ввода:
3
Пример вывода:
12,15,18,21,24,27,30,33,36,39,42,45,48,51,54,57,60,63,66,69,72,75,78,81,84,87,90,93,96,99
ПОКАЗАТЬ ОТВЕТЫ
Yaroslav1640
24.09.2020 12:35
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
var a,i:integer;
begin
write('Введите число ');
readln(a);
for i:=10 to 99 do
if i mod a = 0 then writeln(i,' кратно ',a);
end.
Тестовое решение:
Введите число 6
12 кратно 6
18 кратно 6
24 кратно 6
30 кратно 6
36 кратно 6
42 кратно 6
48 кратно 6
54 кратно 6
60 кратно 6
66 кратно 6
72 кратно 6
78 кратно 6
84 кратно 6
90 кратно 6
96 кратно 6
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
redridinghood1
08.03.2019 09:10
Вклетки эт введены следующие формулы: a1=8 a2=a1*10 a3=a2-a1 b1=a2/4 b2=(b1-a1)/6 вычислите значения, которые будут отображены на экране в клетках эт....
Кириииил
09.09.2020 06:50
На компьютере ученика в папке «7 класс» есть файлы, которые он хочет сохранить в облачном хранилище («в облаке»). Вычисли, сколько места в Кб займут файлы из папки,...
kristinka75
18.10.2021 10:20
Покажите число 116, данное в восьмеричной системе счисления, в двоичной системе счисления....
привет948
15.06.2019 07:30
Напишите программу ,которая выводит на экран ф.и.о. ,среднее значение из трех чисел....
vagiz7000
15.06.2019 07:20
Дано: a=91 в шеснадцатиричной,b=352 в восьмиричной. какое из чисел с, записанных в двоичной системе счисления, удовлетворяет неравенству a 100010012 100011002 110101112...
Alexandra0903
02.11.2020 10:40
1) При каком значении аргумента функция достигает своего наименьшего (наибольшего)значения?2) Определив закономерность функциональ-ной зависисмости, найдите f(-2)...
Gfykfyj
02.11.2020 10:40
Що втратила і що здобула людина, ставши гуллівером...
poeticclown
02.11.2020 10:40
The History of the London Pollca In 1700 London had no policemen aus. A few men erected the city streets at night,Many people were poor and there were so many thieves...
TTpopoK
02.11.2020 10:40
Подумайте о ком вспоминает Сусанин, к кому обращены его последние слова? 5 эмоций из оперы Иван Сусанин...
тогжан09
02.11.2020 10:40
для спортивнрй команды купили 133 майки и 171 футболки Найдите возможное наибольшре число спортсменов в команде если треьуется чтобы каждый спортсмен получил одинаковый...
Популярные вопросы
Http://russkay-literatura.net/detskaya-literatura/97-prisposobilsya-bianki.html...
2
Познач речення у якому вигук або звуконаслідувальне слово треба...
2
A1461.Решите системы уравнений словения:...
3
A) Заполните схемуЭЛЕМЕНТЫ В ОРГАНИЗМЕЧЕЛОВЕКАF Fe Cu I...
2
4. точки 4 (-9: 1) b(-1: 5), c (8,2), d (- 6-5) - вершины прямоутольной...
3
Найдите решение систем уравнений (1261—1263): 2x – 3y +1+ (х...
1
Read these recipes and fill in the gaps with the correct verbs....
1
Колено показанное на рисунке, находится в равновесии, массу колена...
2
Определите кинетическую энергию яблока весом 200 г при падении...
2
Circle the correct words. 1)I hate it when my baby sister pulls/hangs...
3
//Продвинутый вариант
Var
n:integer;
begin
readln(n);
range(10,99).Where(x -> x mod n=0).Print(',');
end.
//"Школьный" вариант
Var
i,n:integer;
begin
readln(n);
for i:=10 to 99 do
if i mod n=0 then write(i,',');
end.
Пример ввода:
3
Пример вывода:
12,15,18,21,24,27,30,33,36,39,42,45,48,51,54,57,60,63,66,69,72,75,78,81,84,87,90,93,96,99
var a,i:integer;
begin
write('Введите число ');
readln(a);
for i:=10 to 99 do
if i mod a = 0 then writeln(i,' кратно ',a);
end.
Тестовое решение:
Введите число 6
12 кратно 6
18 кратно 6
24 кратно 6
30 кратно 6
36 кратно 6
42 кратно 6
48 кратно 6
54 кратно 6
60 кратно 6
66 кратно 6
72 кратно 6
78 кратно 6
84 кратно 6
90 кратно 6
96 кратно 6