Найти сумму цифр в паскале (используя while или repeat) s=101+103+ +301 составить программу.

1988katerinkam 1988katerinkam    3   20.09.2019 19:30    3

Ответы
Валоронтеа Валоронтеа  08.10.2020 05:17
// PascalABC.NET 3.3.5, сборка 1636 от 10.03.2018
// Внимание! Если программа не работает, обновите версию!

1. Современное решение (приводится в качестве контрольного примера, дающего эталон суммы).

begin
  Range(101,301,2).Sum.Println
end.

Результат
20301

2. Цикл while

begin
  var (i,k,s):=(101,301,0);
  while i<=k do begin s+=i; i+=2 end;
  s.Println
end.

3. Цикл repeat

begin
  var (i,k,s):=(101,301,0);
  repeat
    s+=i; i+=2
  until i>k;
  s.Println
end.

Результаты выполнения всех трех программ одинаковы.
ПОКАЗАТЬ ОТВЕТЫ
wiiiikkkkaaa wiiiikkkkaaa  08.10.2020 05:17
(использую repeat)
var i,S:integer;
begin
S:=0; i:=101;
repeat
S:=S+i; i:=i+2;
until i>301;
Writeln(S);
end.

(использую While)
var i,S:integer;
begin
S:=0; i:=101;
while i<=301
do begin
S:=S+i; i;=i+2;
end;
Writeln(S);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика