Найти первый отрицательный элемент массива с цикла с постусловием repeat < тело > until < условие > напишите программу на паскале

qqvikaglazynova qqvikaglazynova    3   12.09.2019 12:50    1

Ответы
ВикторикаРоэн ВикторикаРоэн  07.10.2020 09:41
Const n=10;
var a:array[1..n] of integer;
i: integer; 
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(41)-20;
 write(a[i]:4);
 end;
writeln;
i:=0;
repeat
i:=i+1;
until (i>=n)or(a[i]<0);
if a[i]>=0 then writeln('Нет отрицательных элементов')
else writeln('Первый отрицательный элемент = a[',i,'] = ',a[i]);
end.

Пример:
Массив A:
   8   7   0  18 -13  -9   6 -16 -13  -2
Первый отрицательный элемент = a[5] = -13
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика