найти ошибку в программе PascalABC.NET Далеко не все в Тентуре имеют право носить малиновые штаны, и конечно, не все владеют пепелацем с гравицапой, зато один предприимчивый чатланин поставил несколько ловушек, захватывающих отваливающиеся детали с пролетающих мимо инопланетных кораблей. Каждое утро он их обходит, в надежде, что рано или поздно из этих запчастей ему удастся собрать какое-нибудь транспортное средство. Путь свой чатланин планирует по карте, на которой аккуратно отмечены ловушки, отсчитывая начало координат от собственного дома. Начинается обход от дома, и в нем же и заканчивается.

Требуется определить, какое расстояние проходит чатланин за день.

В первой строке входного файла INPUT.TXT находится натуральное число N – количество ловушек, установленных чатланином (N ≤ 10), далее следуют N строк формата «X Y», описывающих координаты ловушек в порядке их обхода (-10 ≤ X,Y ≤ 10; X,Y – целые числа).

В выходной файл OUTPUT.TXT выведите общее расстояние, которое пройдет чатланин, обойдя все ловушки в приведенном порядке и вернувшись в начало координат от последней ловушки, с точностью до трех знаков после запятой.

Вот сама программа:
function len(x1,y1,x2,y2:integer):double;
begin
len:=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2))
end;
var x1,y1,y2,x2,n,i:integer;
l:real;
begin
x1:=0;
y1:=0;
read(n);
for i:=1 to n do begin
read(x2,y2);
l:=len(x1,y1,x2,y2);
x1:=x2;
y1:=y2;
l:=l+len(x2,y2,0,0);
end;
writeln(l:2:3);
end.


найти ошибку в программе PascalABC.NET Далеко не все в Тентуре имеют право носить малиновые штаны, и

alenali2016p0doga alenali2016p0doga    2   13.12.2020 22:02    23

Другие вопросы по теме Информатика