найти ошибку! Написать программу на СИ, запрашивающую у пользователя в бесконечном цикле число и выводящую среднее значение всех введённых ранее чисел. Вывод в формате: "Среднее значение этих ... чисел равно ...". Среднее значение выводить с точностью до 5 десятичных знаков (т.е. до 1/100000).

Программа перестаёт работать или при вводе символа вместо числа, или при истечении 1 минуты с момента ввода первого числа.

Или найти ошибку

#include // Библиотека для работы с функциями ввода-вывода

#include // Библиотека для указания локации (региональной кодировки)

#include // Библиотека математических функций

#include // Библиотека для работы с временем

int main() {

setlocale(LC_ALL, "Rus");

time_t start, end;

int timelim = 60;

int a = 0;

int i = 1, s;

float c;

start = time(NULL);

end = time(NULL);

for ( ; difftime(end, start) < timelim; end = time(NULL)) {

for (i = 1; i > 0; i++) {

printf("Введите число:\n");

scanf_s("%d", &s);

a += s

c = a / i;

if (scanf_s("%d", &s) < 1) {

printf("Только числа нужны нам. Ошибку допустил ты...\n");

return 0;

}

printf("Среднее значение этих %d чисел равно %.3f ", i, c);

}

printf("Ваше время истекло...\n");

printf("Пока!\n");

return 0;

}

gerad34343 gerad34343    1   22.02.2022 17:01    4

Другие вопросы по теме Информатика