tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Найти max{min(a,b), min(c,d)}
Найти max{min(a,b), min(c,d)} написать на паскале.оператор if без всяких function
NikolayTop
3 23.07.2019 09:10
6
Ответы
данил20601
03.10.2020 11:32
Var a,b,c,d,min1,min2,max:integer;
begin
write('a = '); readln(a);
write('b = '); readln(b);
write('c = '); readln(c);
write('d = '); readln(d);
if a<b then min1:=a else min1:=b;
if c<d then min2:=c else min2:=d;
if min1>min2 then max:=min1 else max:=min2;
writeln('max = ',max);
end.
Пример:
a = 5
b = 2
c = 1
d = 4
max = 2
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Dimaaaaaaasiiiiiik
05.05.2019 16:45
45 подскажите код на с# для закрытия windows forms, чтобы он о выходе из программы типа вы точно хотите выйти? и да нет...
Stasya1985
10.09.2019 22:30
Какое устройство компьютера хранит программы и данные только когда компьютер включен?...
yzenik2
05.03.2021 14:22
Что будет выведено на экран A равно 5 B равно 6 Print a11 5 6 1...
ayzilyamannano
05.03.2021 14:22
1. Найпопулярнішою ділянкою використання тривимірної графіки є... а) кіно; б) комп’ютерні ігри; в) машинобудування; г) проектування.2. Створення тривимірної моделі сцени і об’єктів...
EfremovMk
13.01.2022 15:04
Python как написать последевотельность которая вычисляет число квадрата минус 1 тоесть n**2 - 1 с каждого предыдущего числа как написано здесь 2, 3, 8, 63, 3968 и так далее...
Варька111111111
13.01.2022 14:58
7“. Складіть проект, у якому виконавець намалює відрізок завдовж- ки 50 кроків синім кольором, якщо натиснуто клавішу стрілка вправо, або намалює відрізок завдовжки 100 кроків червоним...
valeriya210322
13.01.2022 14:56
Напишите программу, которая заполняет массив из N = 10 элементов случайными числами в диапазоне [0,20] и сортирует его в порядке убывания. Пример:Массив: 5 16 2 13 3 14 18 13 16 9Сортировка:...
egorbroggo
13.01.2022 14:47
решить информатика , если правильно будет отблагодарю суммой 3 задание 5 строчка, если будут вопросы пишите...
alexeyzlodei
13.01.2022 14:42
Представьте следующие десятичные числа в виде позиционной записи: а) 576; б) 842,3; в) 1924,803; г) 1000; д) 0100,0001; е) 0,002; ж) 25,75; з) 89; и) 13,5; к) 0,25; л) 834,25; м) 34226;...
виктория123600
25.05.2021 15:26
Вставьте пропущенные слова.При знакомстве с языком программирования Python мы столкнемся с тремя типами данных:целые числа (1) - положительные и отрицательные целые числа, а также...
Популярные вопросы
Втечение трех дней магазин игрушек получил 800000 тг дохода.из них 35%от продажи...
3
1. расположите элементы в порядке ослабления металлических свойств : se k as ca...
3
Составить 5 пастбищных цепей по плану: продуценты - консументы 1 порядка - консументы...
3
Кпричинам смутного времени относятся: а) недовольство крестьян введением рекрутской...
1
Всего 2010 символов докажите, что число является составным....
2
Первая мировая война! в названии этого смешанного подразделения, сформированного...
1
Уякій пісні дівчина передає почуття туги за коханим, який далеко від дому? ...
2
Вв 1 литре 1000 миллилитров .чайная ложка вмещает 6 мл лекарства.больному коту днём...
2
Нужно: 1. семена льна содержат 29% масла. сколько масла можно получить из 120 кг...
3
Решите уравнение 0,6*(x+7)-0,5(x-3)=6,8...
1
begin
write('a = '); readln(a);
write('b = '); readln(b);
write('c = '); readln(c);
write('d = '); readln(d);
if a<b then min1:=a else min1:=b;
if c<d then min2:=c else min2:=d;
if min1>min2 then max:=min1 else max:=min2;
writeln('max = ',max);
end.
Пример:
a = 5
b = 2
c = 1
d = 4
max = 2