Найдите ошибку в коде! : написать программу, которая бы рассчитывала значение выражения по формуле: (ln|cos(x)|)/(ln(1+x^2). мой код: program formula; var x: integer; y: real; begin write('vvedute x '); readln(x); y: =(ln(abs(cos(/ln(1+cos(x*x)); writeln('y=',y: 5: 2); end. почему то выдаёт ошибку. что не так?

Berkutmen Berkutmen    2   13.06.2019 00:40    3

Ответы
няшка367 няшка367  02.10.2020 00:53
Program formula;
var
  x:integer;
  p,y:real;
begin
  Write('vvedute x<>0 ->');
  Readln(x);
  if x=0 then Writeln('x=0 nedopustimo')
  else begin
    p:= abs(cos(x));
    if p=0 then Writeln('ln(0) v 4islitele')
    else begin
      y:=ln(p)/ln(1+sqr(x*x));
      Writeln('y=',y:5:2)
    end
  end
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика