tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Нарисовать блок-схему и программу
Нарисовать блок-схему и программу по ней на языке с++. входные данные a, d - матрицы n*n, b,c - вектора размерности n*1. выходные данные: d*c+3*b
мышка72
3 29.07.2019 02:20
2
Ответы
geklaoycd9v
27.09.2020 06:33
Только программа, блок-схему не знаю
#include <iostream>
#include <iomanip>
#include <vector>
#include <ctime>
int main()
{
using namespace std;
const int n = 5;
int A[n][n];
int D[n][n];
vector<int> B(n);
vector<int> C(n);
vector<int> S(n); //результирующий вектор
//как-нибудь заполняем исходные матрицы и вектора
srand(time(0));
for (int i = 0; i < n; ++i)
{
for (int j = 0; j < n; ++j)
{
A[i][j] = rand() % (n * n) - n * n / 2;
D[i][j] = rand() % (n * n) - n * 2;
}
B[i] = rand() % (n * n) - n;
C[i] = rand() % (n * n) - n * n + n;
}
//выведем исходные данные на экран
cout << "matrix A:\n";
for (int i = 0; i < n; ++i)
{
for (int j = 0; j < n; ++j)
cout << setw(5) << A[i][j];
cout << endl;
}
cout << "\nmatrix D:\n";
for (int i = 0; i < n; ++i)
{
for (int j = 0; j < n; ++j)
cout << setw(5) << D[i][j];
cout << endl;
}
cout << "\nvector B:\n";
for (int i = 0; i < n; ++i)
cout << setw(5) << B[i] << endl;
cout << "\nvector C:\n";
for (int i = 0; i < n; ++i)
cout << setw(5) << C[i] << endl;
//вычислим требуемое
for (int i = 0; i < n; ++i)
{
S[i] = 0;
for (int j = 0; j < n; ++j)
S[i] += D[i][j] * C[j];
S[i] += 3 * B[i];
}
//выведем результат на экран
cout << "\nvector S = D * C + 3 * B:\n";
for (int i = 0; i < n; ++i)
cout << setw(5) << S[i] << endl;
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Пвлчлчпс
02.11.2020 15:39
Сурет ушбұрыш, шенбер, төртбурыш сиякты геометриялык пішіндер аркылы курылады. расарлык турлы тусты векторлык геомятриялык 1 из...
Cuba125
02.11.2020 15:39
Какой самый лучший уберечь себя от вредный воздейств Wi Fe...
незнаякаилизнайка
02.11.2020 15:40
Числом в нормальной форме с нормализованной мантистой является: 1) 1997 2) 0,341 x 10⁹ 3) 213, 5629 4) 0,002311...
ggez2
02.11.2020 15:40
Сколько байтов и битов в слове учебник? Сколько байтов и битов с слове клавиатура?Сколько байтов и битов в слове модем?...
ViktorVivat
12.11.2020 17:28
Составьте программу на языке Паскаль для вычисления значения функции y=(4+3x)/(3+6x) при любом x...
Killerman68
12.11.2020 17:27
Решите 600 в двоичной системе .*Решение в столбик....
apivo
25.01.2021 11:33
много ,не проходите мимо Чем была вызвана оборона Корелы В1610 году?...
Anolu
25.01.2021 11:33
Как стать творческим человеком? Прослушай текст притчи. Определи тему притчи.как стать интересным собеседникомкак научиться писатькак стать успешнымкак стать творческим человеком...
далекоотсолнца
25.01.2021 11:33
Решите надо решить того 6 заданий и все заранеее...
камидь
25.01.2021 11:33
Решите уравнение lg (9x + 10) =2...
Популярные вопросы
Емоцыональный диалог друзей после просмотра фильма....
3
Обчисліть об єм карбон(IV) оксиду, що утвориться при спалюванні етену об ємом...
2
знайдіть висоту рівньостороннього трикутника, сторона якого дорівнює 6 см. Розв...
3
Площадь треугольника ABC равна S. Найти площадь заштрихованной фигуры, если:...
3
Стороны параллелограмма равны 8 см и 8 см, а угол между ними равен 120°. Чему...
3
Общие и индивидуальные характеристики мифов и легенд....
1
Найди глаголы, у которых в окончании допущень спряжение всех глаголов.прилетите...
2
126-беттегі 16-тапсырмадағы кестені толтырыңдар тексті жау талындағы бала...
3
Приведите примеры покрытосеменных : Медоносы, кориовые...
2
Проблемы экологии. Правописание безударных личных окончаний глаголов в настоящем...
1
#include <iostream>
#include <iomanip>
#include <vector>
#include <ctime>
int main()
{
using namespace std;
const int n = 5;
int A[n][n];
int D[n][n];
vector<int> B(n);
vector<int> C(n);
vector<int> S(n); //результирующий вектор
//как-нибудь заполняем исходные матрицы и вектора
srand(time(0));
for (int i = 0; i < n; ++i)
{
for (int j = 0; j < n; ++j)
{
A[i][j] = rand() % (n * n) - n * n / 2;
D[i][j] = rand() % (n * n) - n * 2;
}
B[i] = rand() % (n * n) - n;
C[i] = rand() % (n * n) - n * n + n;
}
//выведем исходные данные на экран
cout << "matrix A:\n";
for (int i = 0; i < n; ++i)
{
for (int j = 0; j < n; ++j)
cout << setw(5) << A[i][j];
cout << endl;
}
cout << "\nmatrix D:\n";
for (int i = 0; i < n; ++i)
{
for (int j = 0; j < n; ++j)
cout << setw(5) << D[i][j];
cout << endl;
}
cout << "\nvector B:\n";
for (int i = 0; i < n; ++i)
cout << setw(5) << B[i] << endl;
cout << "\nvector C:\n";
for (int i = 0; i < n; ++i)
cout << setw(5) << C[i] << endl;
//вычислим требуемое
for (int i = 0; i < n; ++i)
{
S[i] = 0;
for (int j = 0; j < n; ++j)
S[i] += D[i][j] * C[j];
S[i] += 3 * B[i];
}
//выведем результат на экран
cout << "\nvector S = D * C + 3 * B:\n";
for (int i = 0; i < n; ++i)
cout << setw(5) << S[i] << endl;
return 0;
}