Напишите следующую программу. введите с клавиатуры целое число n. выведите на экран числа от 1 до n так, чтобы каждое число выводилось столько раз, каково его значение. например, если с клавиатуры введено 6, то на экране мы должны увидеть: 1 2 2 3 3 3 4 4 4 4 5 5 5 5 5 6 6 6 6 6 6 написать программу нужно как можно проще в программе pascalabc

yibiuninmk yibiuninmk    1   31.05.2019 00:40    3

Ответы
Turtle183119 Turtle183119  01.07.2020 10:17
Вообщем, сделал задачу, но метод пузырька уже не выйдет :) т.е. сортировка по возрастанию :( упрощал как мог.

Program asd;
USES crt;
Var n,m,i,j:integer;
BEGIN
Clrscr;
Writeln('Введите число n: ');
Readln(n);
n:=n+1;
For i:=1 to n do 
 begin n:=n-1; 
   For j:=1 to n  do   
     begin   
      Write(n:3); 
     end; 
end;
END.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика