Напишите программы в паскале: 1) цикл с предусловием. написать программу, вычисления у=х2 при х=2, 4, 6, 8, 10; 2) цикл с постусловием. написать программу, в которой требуется вводить с клавиатуры числа и подсчитывать их сумму, до первого введенного отрицательного числа; 3) цикл параметром. написать программу, которая находит сумму чисел от 1 до 20

veronika4848 veronika4848    3   19.08.2019 15:10    1

Ответы
qsn50857 qsn50857  26.08.2020 07:05
Program n1;
var y, x: integer;
begin
x:=0;
while x<10 do begin
x:=x+2;
y:=x*x;
writeln(y);
end;
end.

Program n2;
var x, sum: real;
begin
sum:=0;
repeat
readln(x);
if(x>=0) then sum:=sum+x;
until x<0;
writeln(sum);
end.

Program n3;
var a, i: integer;
begin
a:=0;
for i:=1 to 20 do a:=a+i;
writeln(a);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика