Напишите программы на pascalabc.net
№5:
напишите программу, которая в последовательности натуральных чисел определяет среднее значение нечетных чисел, которые меньше 50. программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность). количество чисел не превышает 100. введённые числа не превышают 300. программа должна вывести одно число: среднее значение четных чисел меньших 50.
например: 23 118 11 48 15 34 0 ==> 16.33
(вывод два знака после запятой)

pavlovaanastasia30 pavlovaanastasia30    1   29.11.2019 16:22    2

Ответы
хомяк2005 хомяк2005  10.10.2020 17:06

begin

 Write(ReadSeqIntegerWhile(p -> p <> 0)

   .Where(p -> p.IsOdd and p.InRange(1,49))

   .DefaultIfEmpty

   .Average:0:2)

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика