Напишите программу запрашивающую 3 числа и выводящую их в порядке возрастания.

yuriayato yuriayato    3   15.09.2019 23:20    4

Ответы
Victor789 Victor789  07.10.2020 18:32
1 фото в порядке убывания
2 в порядке возрастания

тебе надо 2:

Program Rick_and_Morty;
var x,y,z:integer;

Begin
write('введите 1 число: ');
readln (x);
write('введите 2 число: ');
readln (y);
write('введите 3 число: ');
readln (z);

if ((x<=y) and (x<=z))then
  begin    if (y<=z) then
  writeln(x,',',y,',',z)  
  else
  writeln(x,',',z,',',y);
    end
else

if ((y<=x) and (y<=z))then
  begin
  if (x<=z) then
  writeln(y,',',x,',',z)
  else
  writeln(y,',',z,',',x)
  end
else

if ((x<=y)) then
  writeln(z,',',x,',',y)
  else
  writeln(z,',',y,',',x);

writeln('конец');
end.
Напишите программу запрашивающую 3 числа и выводящую их в порядке возрастания.
Напишите программу запрашивающую 3 числа и выводящую их в порядке возрастания.
ПОКАЗАТЬ ОТВЕТЫ
Тявка1 Тявка1  07.10.2020 18:32
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!

Begin
var (a,b,c):=ReadInteger3('a, b, c ->');
var x:= min(a,min(b,c));
var y:= max(a,max(b,c));
var z:= 0;
if (a <> x)and(a <> y)
  then z:= a;
if (b <> x)and(b <> y)
  then z:= b;
if (c <> x)and(c <> y)
  then z:= c;
Writeln(x, ' ', z, ' ', y);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика