Напишите программу, заполняющую массив из 45 элементов случайными числами от 0 до 34, выводящую полученный массив на экран, прозврдящую поиск элементов, делящихся на 3, подсчитывающую их количество (с выводом на экран) и считающая среднее арифметическое таких элементов

OctavisicStar691 OctavisicStar691    3   21.08.2019 09:40    3

Ответы
rustamzade2018 rustamzade2018  05.10.2020 09:09
Program n1;
const n=10;
var a: array [1..n] of integer;
i,sum,k: integer;
begin
randomize;
for i:=1 to n do
begin
a[i]:=random(34);
write(a[i],' ');
end;
writeln;
sum:=0;
k:=0;
for i:=1 to n do if a[i] mod 3 = 0 then
begin
k:=k+1;
sum:=sum +a[i];
end;
writeln('кол-во: ',k);
writeln('сумма: ',sum);
writeln('ср. арифм: ',sum/k);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика