Напишите программу вычисления выражения на C++:
99 – 98 + 97 – 96 + 95 – 94 + ... + 5 – 4 + 3 – 2 + 1

yuliyaefremova3 yuliyaefremova3    3   11.05.2021 08:43    9

Ответы
Группа134ПО Группа134ПО  11.05.2021 08:50

99-98+97+96+95-94+6+5-4+3-2+1

а?

ПОКАЗАТЬ ОТВЕТЫ
асел9 асел9  11.05.2021 08:50

#include <iostream>

using namespace std;

signed main() {

int s = 0;

for (int i = 99; i >= 1; i--) {

 if ((i & 1) == 0)

  s -= i;

 else

  s += i;

}

cout << s;

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика