Напишите программу вычисления площади и гипотенузы прямоугольного треугольника ,если известны его катеты. но программа должна быть с комментариями посторочно

hickov2003 hickov2003    1   25.09.2019 13:00    3

Ответы
Merlin6666 Merlin6666  08.10.2020 18:27
Var {раздел описания переменных}
a, b: Real; {описание переменных. Переменные а и b вещественного типа}

begin {раздел или блок непосредственно кода программы}
WriteLn('введите катеты'); {запрос ввода сторон треугольника}
ReadLn(a,b); {ввод сторон треугольника пользователем}
Writeln('Площадь треугольника =',a*b/2); {вывод результата нахождения площади треугольника. Площадь равна половине произведения катетов}
WriteLn('Гипотенуза=', sqrt(sqr(a) + sqr(b))); {вывод результата нахождения гипотенузы. Квадрат гипотенузы равен сумме квадратов катетов, соответственно гипотенуза равна корню квадратному из суммы квадратов катетов. sqr - возведение в квадрат, sqrt - корень из числа.}
end. {Конец кода программы}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика