tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напишите программу вычисления
Напишите программу вычисления наименьшего общего кратного в следующих четырех чисел : 36,54,18 и 15 . используйте процедуру вычисления наибольшего общего делителя двух чисел.
shevyakova2018
2 15.09.2019 14:10
1
Ответы
Dronton
07.10.2020 17:25
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!
function HOK(a,b:integer):integer;
begin
Result:=a*b;
while b>0 do (a,b):=(b,a mod b); // a - НОД
Result:=Result div a
end;
begin
Writeln('НОК(36,54,18,15)=',HOK(HOK(36,54),HOK(18,15)))
end.
Результат
НОК(36,54,18,15)=540
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Khajiit999
11.03.2019 21:50
Определите, что будет напечатано в результате работы следующей программы: var s,k integer; begin s: =0; for k: =3 to 8 do s: =(s+3)*k; write(s); end. p.s. желательно...
anyanice7
23.05.2020 23:50
Візуальні дії які відтворюються під час появи слайдів комп ютерної презентації...
kadalsu4
24.05.2020 12:38
Контрольная работа по информатике Обобщение знаний материала Вариант 1 1. Переведи из двоичной системы в десятичную восьмеричную, и 16-ричную: 1) 1101002 = 2) 111110112...
лом15
24.05.2020 12:38
6. Производится одноканальная (моно) звукозапись с частотой дискретизации 16 кГц и 32-битной разрядностью дискретизации. Запись длится 4 минуты, ее результаты записываются...
авлвк5
24.05.2020 12:52
Які існують форми подання алгоритмів?...
Maryana1069
24.05.2020 12:38
Яке призначення табличного процесора Excel?...
juliati88tan
23.05.2020 13:24
Скорость передачи данных через модемное соединение 28 Кбит/сек. Передача текстового файла заняла 10 с. Определите сколько символов содержал переданный текст, если известно,...
Russland2000
23.05.2020 13:15
ОТВЕТЫ БУДУТ В С У ПОЛЬЗОВАТЕЛЯ О Во Сколько единиц в двоичной записи шестнадцатеричного числа 3FE ? Какое из неравенств выполняется для чисел А = 6507 , В = 4759 и...
misterzol1
23.05.2020 13:27
ПОТОГИТЕ СРЧ ХАЛЯВНЫЕ ОТВЕТЫ БУДУТ В С У ПОЛЬЗОВАТЕЛЯ О Во Сколько единиц в двоичной записи шестнадцатеричного числа 3FE ? Какое из неравенств выполняется для чисел...
Розочка2018
24.05.2020 13:20
Реставрация книги — это перемещение файла, файловая система, модификация файла, удаление файла, копирование файла. надо выбрать что-то одно, и объясните !...
Популярные вопросы
Укажите принципы/идеи правового государства утверждённые в Конституции...
2
1. В предмете «Технология» изучаются: А. технологии производства...
1
ВО ДЛЯ 8 ИЛИ ВЫШЕ КЛАССАРешите задания в документе...
1
Потенціальна енергія тіла, яке перебуває на висоті в спокою 900...
1
Какие структуры клетки состоят из микротрубочек? Варианты: 1.Клеточный...
3
КАК РЕШИТЬ ОЧЕНЬ НАДАПрочитати твір Сіроманець . Знову твір про...
2
визначте напругу на кінцях сталевого провідника довжиною 250 см...
1
1. Осевое сечение конуса – треугольник, площадь которого равна ,...
2
Угол abd равен 50 градусам угол bcd равен 20 градусам найдите угол...
2
Вычислите массу натрия хлорида и объем воды необходимые для приготовления...
1
// Внимание! Если программа не работает, обновите версию!
function HOK(a,b:integer):integer;
begin
Result:=a*b;
while b>0 do (a,b):=(b,a mod b); // a - НОД
Result:=Result div a
end;
begin
Writeln('НОК(36,54,18,15)=',HOK(HOK(36,54),HOK(18,15)))
end.
Результат
НОК(36,54,18,15)=540