tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напишите программу вычисления
Напишите программу вычисления наибольшего общего делителя двух натуральных чисел. используйте оператор repeat,while.
asya13051
3 01.06.2019 05:10
6
Ответы
podshchipkova
02.07.2020 12:56
Function NOD(a, b: integer): integer;
begin
while a <> b do
if a > b then a := a - b
else b := b - a;
NOD := a
end;
begin
writeln('НОД(264;5436)=', NOD(264, 5436))
end.
Тестовое решение:
НОД(264;5436)=12
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
TheAlexKillGame
22.04.2021 15:36
Снюс снюсснюс снюсснюс снюс...
alisabeletzkay
22.04.2021 15:36
Визначити ефективність роботи алгоритмів сортування. Порахувати кількість порівнянь, виконаних у програмі. Порахувати кількість обмінів, виконаних у програмі. Определить...
rsdfa
22.04.2021 15:35
Яким буде результат виконання даної програми якщо мишку натиснути...
davaispi
22.04.2021 15:33
написать программу, которая получает два целых числа А и В (0...
san11217
24.12.2020 10:55
Проекты SketchUp Make сохраняются в формате **.skp*.mp3*.mov...
Mashirachan
24.12.2020 10:55
Деловая графика графическая возмоности табличного процесора MS Excel 2010...
alenazakhar2000al
27.09.2019 16:01
Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел кратных 7, оканчивающихся на 5. программа получает на вход количество последовательных...
Sasho2325
27.09.2019 16:01
Макро, микро и мега объекты, примеры...
Сергииенко
26.01.2022 23:26
Определите наименьшее натуральное число A, при котором выражение & → & ∨ &тождественно истинно (то есть принимает значение 1 при любом натуральном значении переменной...
fdimon
26.01.2022 23:33
Решите уравнение: 46 в 10 системе счисления=56 в х системе счисления...
Популярные вопросы
Решите уравнение √2sin^2(3pi/2+x)=-cosx...
2
Вгороде в на 20% больше жителей, чем в городе а, а в городе с на 10% меньше,...
3
Сколько процентов хлора содержит смесь состоящая из 0,1 моль хлорида магния...
2
Інапишіть будь-ласка про що йдеться в повісті злочинці з паралельного...
3
Впрямоуглольном треугольнике abc угол c=90 градусов, биссектрисы cd и...
3
Луч света падает на границу двух сред под углом, равным предельному углу...
1
Из пункта а в пункт в против течения речки выехала моторная лодка. в дорогое...
1
Пешеход стоит возле второго вагона поезда. поезд тронулся, пешеход заметил,...
2
А1. по данному отрывку назовите автора и его произведение. « взяла из...
2
Решить на одном станке партию деталей можно изготовить за 5 ч на другом...
1
begin
while a <> b do
if a > b then a := a - b
else b := b - a;
NOD := a
end;
begin
writeln('НОД(264;5436)=', NOD(264, 5436))
end.
Тестовое решение:
НОД(264;5436)=12