Напишите программу ввести одномерный массив a из 13 элементов. определить в нём среднее арифметическое тех элементов, которые при делении на 4 остаток 1 или 3. c++

Андрей22111111 Андрей22111111    2   16.06.2019 10:41    7

Ответы
bamnames bamnames  16.06.2019 11:50

ответ:

begin s: =0; n: =0; for i: =1 to 13 do begin readln (a[i]); end; for i: =1 to 13 do begin if (a[i] mod 4 = 1) or (a[i] mod 4 = 3) then begin s: =s+a[i]; n: =n+1; end; end; writeln (s/n); end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика