tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Напишите программу ):
Напишите программу ): ввести 15 целых элементов массива, элемента с нечетными номерами увеличить на 10, элементы с четными номерами уменьшить на 10. вывести на экран
Виктория1950
2 08.07.2019 15:40
0
Ответы
nastya30071
30.08.2020 14:18
USES CRT;
VAR A:array[1..15] of integer;
i:integer;
BEGIN
CLRSCR;
{Заполняем массив}
For i:=1 to 15 do
begin
Write('Введите ',i,' элемент массива ');
Read(A[i]);
CLRSCR;
end;
{Выводим массив на экран}
For i:=1 to 15 do
Write(A[i],' ');
{К нечетным номерам массива +10 к четным -10}
For i:=1 to 15 do
if i mod 2 <>0 then A[i]:=A[i]+10
else A[i]:=A[i]-10;
Writeln;
{Выводим на экран измененный массив}
For i:=1 to 15 do
Write(A[i],' ');
Readln;
READLN;
END.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Nastya0012005
27.10.2020 13:25
Найди общий обьем информации 750 мб + 4,2 гб = мб...
nekodaf
27.10.2020 13:26
Информатика таблица проццесоров...
Айка12390
04.06.2019 22:20
Для того чтобы поместить какой-либо фрагмент текста или рисунка в буфер обмена какую комбинацию клавиш нужно набрать?...
schoolboy371
04.06.2019 22:20
9класс. тема: условные какими будут значения переменных j, k после выполнения условного оператора: if j k then j: =k-2 else dec (k,2); если исходные значения переменных равны: а) j=3,...
turysbekaida
26.02.2020 18:57
Чем быстрее тем лучше! Язык: Паскаль....
ыфыфыф553
22.01.2020 20:09
1. значение цифры не зависит от ее положения в числе в: 1) позиционных системах счисления2) непозиционных системах счисления2. десятичная система счисления – 1) позиционная2) непозиционная3....
baybiboom
22.01.2020 20:07
Что такое проект? примеры проектов из разных областей человеческой деятельности...
mdasa7375
28.11.2019 10:09
Кпд двигается 30% какую полезную работу совершает такой двигатель если нагреватель отдаёт 1000 дж теплоты...
Dilya0608
28.11.2019 10:10
Сделайте свой отзыв по этому плану...
SakuraHarunoo
28.11.2019 10:10
Обчислити ккд двигуна , який для виробництва 29.7 мдж електроенергii використовуе 12 кг бензину? ...
Популярные вопросы
Какие структуры белка изменяются при присоединении конкурентного и неконкурентного...
3
Қожа Ахмет Ясауи кесенесі туралы мағлұмат жазу...
3
Масғұт поэмасынын сюжеттик композициялык талдау ...
2
Соотношение между массами элементов, которые входят в состав данного соединения,...
2
1. Величина острого угла равнобокой трапеции втрое меньше величины тупого угла.Вычислить...
2
Определите истинные высказывания о функциях процессора. № Высказывание И 1 Считывает...
1
У залізну посудину, що має температуру10 С, налили 0,5 кг гарячої води за температури...
1
Доведіть, що сума чисел xyz+yxz+zxy кратне 111...
2
Составьте предложение со словом увитый...
2
Какую роль играют растения для животных?сррчно...
1
VAR A:array[1..15] of integer;
i:integer;
BEGIN
CLRSCR;
{Заполняем массив}
For i:=1 to 15 do
begin
Write('Введите ',i,' элемент массива ');
Read(A[i]);
CLRSCR;
end;
{Выводим массив на экран}
For i:=1 to 15 do
Write(A[i],' ');
{К нечетным номерам массива +10 к четным -10}
For i:=1 to 15 do
if i mod 2 <>0 then A[i]:=A[i]+10
else A[i]:=A[i]-10;
Writeln;
{Выводим на экран измененный массив}
For i:=1 to 15 do
Write(A[i],' ');
Readln;
READLN;
END.