Напишите программу «Визитная карточка», которая выводила бы на экран хорошо оформленные ваши личные данные: имя, фамилию, год рождения, адрес, телефон. Используйте разные цвета, хорошо скомпонуйте. С использованием модуля (CRT)

8877580 8877580    1   28.06.2021 20:42    21

Ответы
Владимир328 Владимир328  28.07.2021 21:32

 

type Man = record

        name: String;

        surname: String;

        date: record

            day: Integer;

            month: Integer;

            year: Integer;

        end;

    end;

 

var people: Array [1..100] of Man;

   i,n,_year: Integer;

   _name: String;

 

begin

   Write('Enter number of man: ');

   ReadLn(n);

   for i := 1 to n do

   With people[i] do

   begin

       WriteLn('Man[',i,']:');

       Write('Enter name: ');

       ReadLn(name);

       Write('Enter surname: ');

       ReadLn(surname);

       Write('Enter birthday Day/Month/Year: ');

       ReadLn(date.day, date.month, date.year);

       WriteLn;

   end;

   Write('Enter year: ');

   ReadLn(_year);

   for i := 1 to n do

   With people[i] do

       if (date.year = _year) then

           WriteLn('Name: ',name,' Surname: ',surname);

   WriteLn;

   Write('Enter name: ');

   ReadLn(_name);

   for i := 1 to n do

   With people[i] do

       if (name = _name) then

       begin

           Write(surname,' ',name);

           WriteLn(' ',date.day,'.',date.month,'.',date.year);

       end;

   ReadLn;

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика