Напишите программу : винипух съедает 100 грамм варенья в первый день, во второй день ещё 100 грамм, в третий день 200 грамм, в каждый последующий день он съедает кол-во варенья равное сумме количества варенья в дня. за сколько дней он съест к грамм варенья? паскаль 10 класс

Maks2801 Maks2801    2   16.08.2019 07:00    2

Ответы
mt111 mt111  02.08.2020 17:27
Var k,k1,k2,kn,n,s:integer;
begin
write('k = ');
readln(k);
k1:=100; 
k2:=100;
s:=k1+k2;
if k<=k1 then n:=1 else n:=2;
while s<k do
 begin
 n:=n+1;
 kn:=k1+k2;
 s:=s+kn;
 k1:=k2;
 k2:=kn;
 end; 
writeln('n = ',n);
end.

Пример:
k = 1100
n = 5
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика