Напишите программу (в тетради) рассчитывающую количество цветов (Y), подаренных на 8 марта девочкам (X) и остаток. Используйте операторы div и mod. X,Y вводите с клавиатуры.

tubip888 tubip888    1   10.03.2021 17:20    7

Ответы
aguscov aguscov  09.04.2021 17:21

program tsveti;

var x,y,z,w:integer;

begin

   write('Введите количество девочек: '); readln(x);

   write('Введите количество цветов: '); readln(y);

   if (y div x) mod 2 = 0 then begin // здесь мы проверяем, не получается ли чётное количество цветков, и если получается чётное, то вычитаем остаток и количество девочек, чтобы добиться нечётного количества

       w := y mod x + x;

       z := (y - w) div x;

   end

   else begin

       w := y mod x;

       z := y div x;

   end;

   writeln('Девочкам подарили по ', z, ' шт. цветков.');

   writeln('Осталось ', w, ' шт. цветков.');

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика