Напишите программу в среде программирования турбо паскаль, которая в последовательности натуральных чисел вычисляет сумму всех однозначных чисел, кратных 3. программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введенные числа не превышают 30000. программа должна вывести одно число: сумму всех однозначных чисел, кратных 3.

RomanReigns2000 RomanReigns2000    1   07.06.2019 09:00    5

Ответы
sofisofiyaSofi sofisofiyaSofi  07.07.2020 07:01
Var  s,n:integer;
begin
  repeat
  readln(n);
  if (n mod 3=0) and (n<10) then s:=s+n;
  until n=0;
writeln('S=',s);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика