Напишите программу в python, вычисляющую наибольший общий делитель двух натуральных чисел, используя алгоритм евклида.

filbert04 filbert04    3   28.12.2019 21:13    2

Ответы
daskatyhg daskatyhg  10.10.2020 23:40

chislo1 = int(input("Введите число а "))

chislo2 = int(input("Введите число b "))

while chislo1 != 0 and chislo2 != 0:

   if chislo1 > chislo2:

       chislo1 = chislo1 % chislo2

   else:

       chislo2 = chislo2  % chislo1

print(chislo1 + chislo2)

Объяснение:

НОД числа:

берутся два числа. большее число = остаток от деления большего на меньшее. Затем опять большее число (может быть уже второе) = остаток от деления большего на меньшее, и так до тех пор, пока одно из них не станет равно 0. И выводится большее число. В случае если числа равны друг другу, находится остаток от деления второго числа на первое: 0, и выводится первое число. Т.е всё работает.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика