Напишите программу в последовательности натуральных чисел определить сумму чисел кратных 5

Den4ik2008228 Den4ik2008228    3   24.07.2019 13:00    7

Ответы
александр199110 александр199110  24.09.2020 01:58
Будем считать последовательность натуральных чисел такую:
1,2,3,4 .. n-1,n
Тогда программа может быть такой:

var
  i, s, n: integer;

begin
  write('Введите число натуральных чисел: ');
  readln(n);
  for i := 1 to n do
    if i mod 5 = 0 then s := s + i;
  writeln('Сумма кратных 5 = ', s);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика