Напишите программу в ПИТОНЕ, которая в последовательности натуральных чисел определяет количество чисел, оканчивающихся на 6. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последова-тельности всегда имеется число, оканчивающееся на 6. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – количество чисел, оканчивающихся на 6.

igoreha3 igoreha3    1   31.05.2020 15:45    59

Ответы
semakina97 semakina97  15.10.2020 12:40

print(len([i for i in [int(input()) for i in range(int(input()))] if i % 10 == 6]))

ПОКАЗАТЬ ОТВЕТЫ
Mocket Mocket  15.10.2020 12:40

def ReadSeq(SeqLen: int, CastType):

   for _ in range(SeqLen):

       yield CastType(input())

def main():

   Sequence = ReadSeq(int(input()), int)

   filtered = filter(lambda p: str(p).endswith('6'), Sequence)

   print(len(list(filtered)))

if __name__ == '__main__':

   main()

Да, моя версия конечно занимает побольше строк, чем другое предложенное решение, но эффективнее расходует память, и, как по мне, немного легче воспринимается на глаз.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика