Напишите программу в ПИТОНЕ, которая в последовательности целых чисел определяет количество нечётных чисел, кратных 3. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности (завершающий 0 не учитывается) и количество нечётных чисел, кратных 3.

liza345789 liza345789    3   31.05.2020 18:13    25

Ответы
VerinaNice VerinaNice  15.10.2020 12:39

вот.............................

Объяснение:

k=0

i=0

x=int(input())

while x!=0:

if x%3==0 and x%2>0:

 k+=1

x=int(input())

i+=1

print(i)

print(k)


Напишите программу в ПИТОНЕ, которая в последовательности целых чисел определяет количество нечётных
ПОКАЗАТЬ ОТВЕТЫ
Гули0203 Гули0203  15.10.2020 12:39

import typing

from typing import Callable

def ReadSeqWhile(SeqType, predicate: Callable[[int], bool]):

   temp = SeqType(input())

   while predicate(temp):

       yield temp

       temp = SeqType(input())

def main():

   RawSequence = ReadSeqWhile(int, lambda x: x != 0)

   Selector = lambda item: (item % 3 == 0) and (item % 2 != 0)

   FilteredSequence = filter(Selector, RawSequence)

   print(f'Число элементов, удовлетворяющих условию: {len( list( FilteredSequence ) )}')

if __name__ == "__main__":

   main()

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика