напишите программу в паскале, я в этом вообще не шарю. На фото задние, нужен 8 вариант​


напишите программу в паскале, я в этом вообще не шарю. На фото задние, нужен 8 вариант​

schabuneva schabuneva    3   08.04.2021 00:30    13

Ответы
Brynd Brynd  08.04.2021 01:00

Program Stepen_chisla;

Var

Z, А : Real; M : integer;

Function Step (N: integer; X:real): real;

Var

I: integer; Y: Real;

Begin

I:=1; Y:=1;

While I<=N do

Begin

Y:=Y*X; I:=I+1;

End;

Step:=Y;

End; {Конец функции}

Begin

Write(‘Введи степень и возводимое число’); Readln(Z,M);

F:=Step(M,Z);

Writeln(Z, ‘ в степени’, M, ‘=’,F);

End.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика