Напишите программу в паскале, . в этой необходимо посчитать суммарную площадь прямоугольников двух видов. известно, что количество всех прямоугольников равно удвоенному значению положительной целочисленной ширины прямоугольников первого вида, и прямоугольников обоих видов — поровну. формат входных данных в единственной строке записаны четыре целых положительных числа h1,w1,h2,w2 (высота и ширина для первого и второго видов прямоугольников соответственно). все числа лежат в диапазоне от 0 до 106 включительно. формат результата выведите единственное число – ответ на . примеры входные данные 1 2 3 4 результат работы 28

Marina22111 Marina22111    2   12.08.2019 22:20    2

Ответы
ezdar04 ezdar04  04.10.2020 14:26
Введем обозначение. Все, относящееся к прямоугольникам первого вида будет иметь индекс 1, ворого вида - индекс 2.
Пусть имеется n₁ и n₂ прямоугольников. По условию n₁+n₂ = w₁ и n₁=n₂, откуда n₁=w₁ и n₂=w₁
Площади: S₁=w₁×h₁, S₂=w₂×h₂
Общая площадь S = n₁×w₁×h₁ + n₁×w₂×h₂ = w₁×(w₁×h₁ + w₂×h₂)

// PascalABC.NET 3.2, сборка 1345 от 24.11.2016
// Внимание! Если программа не работает, обновите её версию!
begin
  var h1,w1,h2,w2:real;
  Read(h1,w1,h2,w2);
  Writeln(w1*(w1*h1+w2*h2))
end.

Пример
1 2 3 4
28
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика