Напишите программу в паскале:
Программа получает на вход 15 натуральных чисел. Напишите программу, которая определит сумму чисел, кратных 11. Программа должна вывести одно число — сумму чисел, кратных 11.

polinaabramova10 polinaabramova10    2   29.04.2020 12:45    4

Ответы
clon255 clon255  29.04.2020 13:30

Сначала вводим n - количество чисел, затем в цикле n раз вводим число, сравниваем с текущим максимальным max, и, если максимальное меньше, вместо максимального записываем текущее число. В качестве начального значения max принимаем 0, т.к. любое натуральное число, делящееся на 4, больше 0.

var

 i, t, max, n: integer;

begin

 readln(n);

 max := 0;

 for i := 1 to n do

 begin

   readln(t);

   if (t mod 4 = 0) and (t > max) then

     max := t;

 end;

 writeln(max);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика

Популярные вопросы