Напишите программу в Паскале, которая заполняет массив из N = 10 элементов случайными числами в диапазоне

[0,20], выводит его на экран, а затем находит индекс

первого элемента, равного введённому числу X.

Программа должна вывести ответ «не найден», если

в массиве таких элементов нет.

Пример:

Массив: 5 16 2 13 3 14 18 13 16 9

Что ищем: 13

A[4] = 13

nekrasovlesha1 nekrasovlesha1    1   15.12.2020 02:40    38

Ответы
freddylolbrO freddylolbrO  14.01.2021 02:41

var a: array [1..10] of integer;

x,i: integer;

k: boolean;

begin

 k:=False;

 randomize;

 for i:=1 to 10 do

   a[i]:=random(21);

 readln(x);

 for i:=1 to 10 do

   if a[i]=x then

   begin

     x:=i;

     k:=True;

     break;

   end;

 if k then

   writeln('a[',x,']=',a[x])

 else

   writeln('не найдено')

end.

Объяснение:


Напишите программу в Паскале, которая заполняет массив из N = 10 элементов случайными числами в диап
Напишите программу в Паскале, которая заполняет массив из N = 10 элементов случайными числами в диап
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика