Напишите программу в паскале "кодирование и декодирование информации" наподобие этой но больше примерно раза в три var a,c: string; i: integer; begin randomize; writeln ('введи фразу'); readln (a); c: =''; for i: =1 to length(a) do begin c: =c+a[i]+chr(random(32)+224); end; write (c); end.

KenDipp KenDipp    2   21.07.2019 09:30    3

Ответы
maksim2657 maksim2657  30.08.2020 21:12
Const
    key = 3;

var
    i: integer;
    s: string;

function Encode(s: string; key: integer): string;
var
    i: integer;
begin
    for i := 1 to Length(s) do
        s[i] := chr(ord(s[i]) + key);
    Encode := s;
end;

function Decode(s: string; key: integer): string;
var
    i: integer;
begin
    for i := 1 to Length(s) do
        s[i] := chr(ord(s[i]) - key);
    Decode := s;
end;

begin
    write('Введите строку данных - ');
    readln(s);
    writeln('Выберите действие');
    writeln('1 - Закодировать');
    writeln('2 - Раскодировать');
    readln(i);
    case i of
        1: s := Encode(s, key);
        2: s := Decode(s, key);
    end;
    Writeln(s);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика