Напишите программу ( в паскале авс), которая вычисляет число пи с заданной пользователем точностью. воспользуйтесь данными и условием предыдущей . (условие предыдущей : напишите программу, которая вычисляет частичную сумму ряда 1-1/3+1/5-1/7+1/ и сравнивает полученное значение с пи/4).

Hyina Hyina    1   18.08.2019 13:30    4

Ответы
чина22 чина22  05.10.2020 02:56
Var s,sgn,eps: real;
    i: integer;
begin
  write('точность вычислений: ');
  readln(eps);
  s:=1;  sgn:= -1;
  i:=3;
  repeat
    s:=s+sgn/ i;
    sgn:= - sgn;
    i:=i+2;
  until 8/i<eps;
  writeln('число пи:  ',s*4);
  writeln('точное значение пи: ',pi);
end.    

точность вычислений: 1.0e-6
число пи:  3.14159240358966
точное значение пи: 3.14159265358979
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика