Напишите программу( в паскале авс), которая находит нок (наименьшее общее кратное) двух чисел, введённых с клавиатуры.

Margaryaanmag Margaryaanmag    2   28.05.2019 02:30    1

Ответы
настя7176 настя7176  25.06.2020 12:55
Для решения этой задачи воспользуемся формулой:
а*б=НОД(а,б)*НОК(а,б)
var a,b:longint;
function nod(a,b:longint):longint;
begin
if a= 0 then
nod:=b else
if b=0 then
nod:=a else
if a>b then
nod:=nod(a mod b,b) else
nod:=nod(a,b mod a);
end;
Begin
read(a,b);
writeln((a*b) div nod(a,b));
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика

Популярные вопросы