Напишите программу в паскале abc, которую вводим последовательность целых чисел заканчивающуюся нулем и определяет верно ли что введеные элементы чередуют знаки, например (2, -2, 3, -3, 4, -4, 5, -5: да знаки чередуются) не используя масивов. либо объясните алгоритм действий

JodiRimmet27 JodiRimmet27    2   28.07.2019 23:00    6

Ответы
Goshavasa Goshavasa  31.08.2020 01:39
Program lol(input, output); var b, a, a1:integer; begin a:=1; b:=0; a1:=-1; repeat begin read (a); if (a/((-1)*a))=(a1/a1) then b:=b+1; if a=0 then break; read (a1); if a <> (-1)*a1 then b:=b+1; end until (a=0) or (a1=0); if b>1 then writeln ('Последовательность не верна') else writeln ('Последовательность верна'); end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика