Напишите программу в paskalabc , которая в последовательности натуральных чисел определяет максимальное чётное число. программа получает на вход количество чисел в последовательности , а затем сами числа . в последовательности всегда имеется чётное число. количество чисел не превышает 1000. введённые числа не превышают 30000.программа должна вывести одно число-максимальное чётное число . пример работы программы : входные данные : 3,10,99,42 выходные данные: 42

гузаля гузаля    2   24.08.2019 09:40    1

Ответы
суады суады  05.10.2020 16:21
Var
N,A,M:word;
Begin
Read(N);
M:=0;
For N:=1 to N do
    Begin
    Read(A);
    if (A>M)and(A mod 2 = 0) then M:=A;
    End;
Write(M)
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика