Напишите программу в паскаль для решения следующей : для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. если первое из них отрицательно, а второе вдвое больше третьего, то выведите среднее арифметическое всех четырех чисел. если произведение этих четырех чисел больше их суммы, то выведите эти сумму и произведение. если выполняются одновременно два перечисленных выше условия, то выведите среднее арифметическое этих чисел, их произведение и сумму. иначе, выведите удвоенные значения этих чисел.

Unforgettable77 Unforgettable77    3   02.06.2019 15:20    5

Ответы
tatarchenko04 tatarchenko04  03.07.2020 10:30
Var a,b,c,d:real;
begin
readln(a,b,c,d);i
f (a<0) and (b/c=2) then
begin
writeln((a+b+c+d)/4);
if a*b*c*b>a+b+c+d then 
begin
writeln(a*b*c*b);
writeln(a+b+c+d);
end;
end
else
writeln(a*2,' ',b*2,' ',c*2,' ',d*2);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика