Напишите программу в паскаль: для n произвольно введенных чисел с клавиатуры вычислить сумму и количество кратных 3 и не кратных 6 и произведение нечетных (на простом уровне)

адэли12 адэли12    1   23.08.2019 16:30    5

Ответы
garcinia garcinia  05.10.2020 14:55
Program n1;
var i,a,sum,k,p,n: integer;
begin
write('введите кол-во чисел: ');
readln(n);
sum:=0;
k:=0;
p:=1;
for i:=1 to n do
begin
write('введите ',i,' число: ');
readln(a);
if (a mod 3=0) and (a mod 6<>0)
then
begin
sum:=sum+a;
k:=k+1;
end;
if a mod 2<>0 then p:=p*a;
end;
writeln('сумма: ',sum);
writeln('количество: ',k);
writeln('произведение: ',p);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика