Напишите программу в pascal , которая из трех введенных с клавиатуры чисел возводит в квадрат положительные, а отрицательные оставляет без изменения.

Hilet Hilet    2   18.07.2019 13:20    7

Ответы
Hockeyist97 Hockeyist97  07.09.2020 15:23
Var
a, b, c: integer;
begin
readln(a, b, c); //вводим a b c
if a > 0 then writeln(a*a) //если a > 0 вывести квадрат a
else
writeln(a); //иначе вывести a
if b > 0 then writeln(b*b) //если b > 0 вывести квадрат b
else
writeln(b); //иначе вывести b
if c > 0 then writeln(c*c) //если c > 0 вывести квадрат c
else
writeln(c); //иначе вывести c
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика