Напишите программу в pascal для этой : найти среднее арифметическое и сумму последовательности положительных чисел

gjkbyf1984 gjkbyf1984    1   28.08.2019 21:50    2

Ответы
муля15 муля15  06.10.2020 01:21
Var a, sum, i : integer; s, x : string; sa : real;
begin sum:=0; readln(s); for i:=1 to length(s) do begin x:=copy(s, i, 1); val(x, a); sum:=sum+a; end; sa:=sum/(length(s)); writeln('сумма: ', sum); writeln('среднее арифметическое: ', sa:4:2);end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика