Напишите программу в Pascal ABC: существует ли треугольник со сторонами а, b, с. Если существует, то какой он - тупоугольный, прямоугольный или остроугольный.

Ghxvbvc13 Ghxvbvc13    2   26.04.2020 16:49    3

Ответы
summercik2009oziid6 summercik2009oziid6  13.10.2020 21:54

var a,b,c: double;

begin

write('Введите a: ');

readln(a);

write('Введите b: ');

readln(b);

write('Введите c: ');

readln(c);

if (a<b+c) and (b<a+c) and (c<a+b) then begin

if (a*a+b*b<c*c) or (a*a+c*c<b*b) or (b*b+c*c<a*a) then

writeln('Треугольник существует. Он тупоугольный')

else if (a*a+b*b=c*c) or (a*a+c*c=b*b) or (b*b+c*c=a*a) then

writeln('Треугольник существует. Он прямоугольный')

else writeln('Треугольник существует. Он остроугольный')

end

else  writeln('Треугольник не существует.')

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика