Напишите программу в которой пользователю предлагается дополнить до 100 некоторое число a(a- случайное число, меньшее 100) ответ пользователя проверяется и комментируете

0304131 0304131    2   25.08.2019 20:40    4

Ответы
sofyabelik sofyabelik  05.10.2020 19:33
Var a,b:integer;
begin
a:=random(99)+1;
write('Дополните до 100 число ',a,': ');
readln(b);
if b=100-a then writeln('Верно!')
else writeln('Вы ошиблись. 100-',a,'=',100-a);
end.

Пример:
Дополните до 100 число 75: 20
Вы ошиблись. 100-75=25
ПОКАЗАТЬ ОТВЕТЫ
nataalferova8 nataalferova8  05.10.2020 19:33
// PascalABC.NET 3.2, сборка 1399 от 08.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('*** Дополните до ста! ***');
  Writeln('Вам будут предлагаться числа, которые нужно дополнять до 100');
  Writeln('Для завершения работы введите 0');
  var a,q,k,m:integer;
  k:=0; m:=0;
  repeat
    q:=Random(1,99);
    Print(q); Read(a);
    if a=0 then break;
    if a=100-q then begin
      m+=1;
      Writeln('Это правильный ответ')
      end
    else Writeln('Это неправильный ответ, ',100-q);
    k+=1;
  until false;
  Writeln('Задано вопросов- ',k,', верных ответов- ',m,' (',100*m/k:0:1,'%)')
end.

Пример
*** Дополните до ста! ***
Вам будут предлагаться числа, которые нужно дополнять до 100
Для завершения работы введите 0
80 20
Это правильный ответ
5 95
Это правильный ответ
51 49
Это правильный ответ
4 95
Это неправильный ответ, 96
90 10
Это правильный ответ
11 0
Задано вопросов- 5, верных ответов- 4 (80.0%)
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика