Напишите программу, в которой пользователь вводит 5-тизначное число, а программа выводит 5-тизначное число-перевертыш. на языке пасхаль

katenkafialkaowy2yf katenkafialkaowy2yf    2   22.08.2019 22:00    4

Ответы
Віка34566 Віка34566  05.10.2020 13:27
Var a,a1,a2,a3,a4,a5,b:integer;
begin
write('a = ');
readln(a);
a1:=a div 10000;
a2:=a div 1000 mod 10;
a3:=a div 100 mod 10;
a4:=a mod 100 div 10;
a5:=a mod 10;
b:=a5*10000+a4*1000+a3*100+a2*10+a1;
writeln('b = ',b);
end.

Пример:
a = 13524
b = 42531
ПОКАЗАТЬ ОТВЕТЫ
isaevads isaevads  05.10.2020 13:27
Так как язык программироваия ты не написал, дам ответ на Си++, в данном примере от чистого Си отличается только вводом выводом (cin,cout-scanf,printf)
Решение:
#include "stdafx.h"
#include <iostream>
using namespase std;
int main()
{
setlocale(0,"");
int A[5];
cout<<"Введите пятизначное число, разделяя каждую цифру пробелом"<<endl;
for(int i=0;i<5;i++)
{
cin>>A[i];
}
cout<<"Перевёрнутое число:"<<endl;
for(int i=4;i>=0;i--)
{
cout<<A[i];
}
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика